Luis Clausín

Webmaster emprendedor a tiempo completo.

Instalar AppServ en Windows 7 64 bits

mayo 24th, 2010 · 28 comentarios

Hace unos días que me compré un ordenador con Windows 7 Home Premiun Edition a 64 bits y la verdad es que me está costando instalar algunos programas más de lo esperado.

Uno de ellos ha sido el servidor local AppServ y es que el problema es que no existe todavía versión a 64 bits y la versión a 32 bits da problemas con el MySQL (al menos a mí, porque aunque he leído en algunos sitios que la versión de 32 bits corre perfectamente sobre un sistema operativo de 64 bits yo no lo he conseguido).

La solución para evitar este problema es instalar la versión de MySQL a 64 bits y luego el AppServ a 32 bits (desactivando en la instalación el MySQL, ya que ya lo habremos instalado previamente).

A continuación pongo los pasos de manera esquemática:

0.- Recordar ejecutar los instaladores con permisos de “Administrador”.

1.-Si hemos instalado previamente alguna versión de Apache o MySQL desinstalarla.

2.- Descargar la versión MySQL a 64bits (Windows  (x86, 64-bit)) de http://dev.mysql.com/downloads/mysql/

3.- Instalar MySQL por medio del ejecutable descargado en el paso 2.

4.- Instalar AppServ a 32 bits (se puede descargar de múltiples sitios). Recordar: Únicamente Apache, PHP y PHPMyAdmin ya que el MySQL lo hemos instalado en el paso 3.

5.- ¡Listo! Así de sencillo.

Tags: webmaster

28 respuestas hasta ahora ↓

  • 1 Carl Lodak // ene 13, 2011 at 0:12

    Estaba en el mismo caso. Me ha sido muy útil. Gracias.

  • 2 Daniel // feb 17, 2011 at 18:28

    Hola Luis, seguí al pie de la letra el protocolo y las expectativas eran alentadoras cuando tecleé …localhost y apareció la entrada de phpMyadmin. El problema vino al introducir clave y contraseña (correctas claro), página en blanco con un error en la línea 276 …

    Os paso la línea de código que aparece:

    ” Fatal error: Declaration of JInstallation::initialise() must be compatible with that of JApplication::initialise() in A:\AppServ\www\joomla_16\installation\includes\application.php on line 276”

    Saludos,

    Daniel.

  • 3 Miguel henostroza // feb 26, 2011 at 3:09

    Hola mira tengo el problema pero con el windows 7 de 32bits lo cual es que se instala todo perfecto pero cuando pongo localhos en el navegador me muestra todo correcto pero cuando voy en phpmyadmin se queda en pantalla en blanco claro que me pide usuario y contraseña lo cual lo pongo pero como le digo se queda en blanco porfa ayudame.

  • 4 Alejandro Mejia // abr 7, 2011 at 1:26

    Para los que quieran la solucion, instale la version 2.5.10 de appserv y todo funciona bien, OS windows 7 Ultimate, 64 bit

  • 5 Sergio Jimenez // may 4, 2011 at 19:35

    Hola,
    Seguí todos los pasos, instalé primero MySQL del link que publicaste e inmediatamente después AppServ2.5.10 deseleccionando MySQL y al finalizar lo probé y nada de nada………….T_T
    ¿Se tiene que configurar algo por separado?

    Saludos!!!

  • 6 raul // may 23, 2011 at 23:27

    hola parece locura pero yo estaba igual despues de entrar al phpadmin todo bien a la hora de llamar a mysql deberas de llamarlo 5 veces con f5 para que carge y te pida el root y password. ya se que suena una locura pero a mi me funciono

  • 7 OSCAR RODRIGUEZ // may 24, 2011 at 22:24

    Hola Compañeros estoy instalando en este momento, pero normalmente esos problemas son de navegador, pruebate con mozilla y desabilita ventanas emergentes y cosas por el estilo.

  • 8 Neon // jun 26, 2011 at 19:13

    Todo Perfecto

    n_n Grax

    Me funciono sin ningun contratiempo.

    No se si sea problema de uds lo del navegador… pero mozilla es 200% mejor que IE Salu2

  • 9 Juanan // jul 26, 2011 at 16:42

    Siguiendo las instrucciones, todo perfecto a la primera. Gracias Luis!!!

  • 10 Benn Sandoval // ago 4, 2011 at 23:57

    Gracias, si no lo haces por separado te marca error 2003, gracias!!!

  • 11 ff // ago 5, 2011 at 16:57

    dok

  • 12 OMAR // ago 31, 2011 at 8:22

    gracias !!!! amigo mio, me funciona perfectamente ahora: congratulation

  • 13 Fernandrock // sep 16, 2011 at 3:19

    A mi me paso lo mismo, pero solo fue con el Home Premium pq antes de comprar esta lap tenia una con Win 7 Home BAsic y ahi si corria bn, no se pq pero ahai si.
    Probe instalarlo asi como tu lo explicas y me funciono, gracias!!

  • 14 Erick Vilchez // sep 18, 2011 at 17:34

    Me funciono de verdad, muchas gracias por el tutorial :)

  • 15 Miyuri // oct 10, 2011 at 17:22

    Gracias me funciono un 100% xD

  • 16 mc // oct 31, 2011 at 7:40

    hola!! solo paso para decir, que habia batallado bastante con esto del servidor… intente con wamp, y nada.. y hasta que llego a este tutorial, y me funciona perfecto el appserv.. en windows 7 64 bits, y asi como esta descrito me funciona perfecto!!

    mil gracias, me salvaste de una grande . saludos!!

  • 17 Hector Gordon // dic 14, 2011 at 20:34

    Saludos a los participantes, he logrado instalar el appserv en mi equipo portatil con windows 7 64bit, ahora bien el probelma es que no puedo instalar Joomla me da un error, alguno tiene referencia de que pueda estar sucediendo?

  • 18 Gonzalo P. // ene 15, 2012 at 6:17

    buenas luis, mi problema radica con php, al momento de iniciarlo no arranca y dice que faltan dll’s en el equipo, los cuales los busque y parche pero aun asi nada, pasa lo mismo con muchos programas en arquitecturas de 64 bits, no saben de donde encontrar php 5 o superior en 64 bits???

  • 19 frUNK // may 6, 2012 at 19:17

    …hay alguna forma de habilitar el AppServ en un W7 Home Basic (64 bits)? -> Porque he hecho todos los pasos mencionado: (Instalacion de MySQL x separado en 64 bits(lo cual si corre y ya la probe en “modo personalizado”) ; luego el Appserv(el 2.5.10). Solo que cuando llamas al AppServ en el navegador sale el: Error 404. En ejecutar/services.msc -> se inicia el Servicio del Apache sale un mensaje q’ no se puede iniciar el servicio, q’ se revise el registro de eventos. Alguna idea con eso?

  • 20 Paul // may 14, 2012 at 11:52

    hola me funciono muy bien gracias ;)

  • 21 Paul A. // may 29, 2012 at 11:00

    El detalle es que se usen una versión mas completa(no usuario) de lo contrario tendran muchas dependencias en la ejecucion con herramientas de desarrollo etc.


    Windows 7 Ultimate 64 bits
    AMD Turion(tm) X2 Ultra Dual-Core Mobile ZM-82(2 CPUs), ~2.2GHz
    4096MB (RAM)

  • 22 Carlos RG // oct 26, 2012 at 21:37

    computador HP i7 (win 7 pro 64 bit) no me permite instalar MySQL, me aparece el siguiente error:
    “could not access network location \hewlett-packard\\”

  • 23 Carlos RG // oct 26, 2012 at 21:38

    ¿Habra alguna idea de que puede ser mi problema con Mysql?

    gracias y saludos.

  • 24 tanya // dic 13, 2012 at 18:19

    perfecto :)

  • 25 juank // feb 10, 2013 at 22:49

    Funciono…. Tengo un windows 8 de 64 bits….

  • 26 Gonzalo // mar 25, 2013 at 12:44

    Obtengo NSIS Error: Error launching installer. Tengo Win7 Home Premium x64, tendrá algo que ver esto?, alguien ha experimentado este problema, como para que pueda orientarme… Saludos y gracias.

  • 27 Luis // ene 1, 2014 at 20:02

    No sé si le sirva a algunos esta información, pero en la versión 2.5.10 en Windows 7 y Windows 8 se soluciona el error de “localhost/phpMyAdmin/” página en blanco. Simplemente iniciando localhost con “127.0.0.1” en la dirección url en lugar que con “localhost”. A mí me funciona perfectamente. Nota: instalas appserver de forma normal, sin instalar el mysql por aparte

  • 28 Pablo // ene 22, 2014 at 16:20

    Luis
    con respecto a la primera recomendación observe que muchas funciones del php tenían problemas cuando interactuaban con las tablas (al instalar por separado el mysql)

Deja tu comentario